Admin API Performance Degradation

Incident Report for Extole

Postmortem

A migration of multiple campaigns caused a performance problem on the campaign API creating a backlog of events. We are investigating long term fixes to prevent this in the future.

Posted Jul 23, 2025 - 03:22 PDT

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 03:21 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 23, 2025 - 03:17 PDT

Monitoring

We have identified the root cause and applied a fix, and are monitoring the improved performance. Campaigns edits will start to be applied now.
Posted Jul 23, 2025 - 03:14 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 23, 2025 - 03:10 PDT

Investigating

We are currently investigating a performance issue with the Admin API that is impacting the ability to change campaigns.
Posted Jul 23, 2025 - 03:06 PDT